Degraded phone support

Incident Report for Server Status | Nexcess

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 22:45 EDT

Monitoring

Our phone system is now back online, and agents should be able to connect and accept calls. We will continue to monitor the system to ensure stability.

Thank you for your continued patience.
Posted Aug 20, 2025 - 21:39 EDT

Investigating

We are currently experiencing issues with our phone system, preventing our agents from connecting/accepting calls. This may cause longer than usual wait times since less agents are available. We are investigating the issue and will provide updates here. We apologize for the inconvenience and appreciate your patience. You can still contact us via case at support@nexcess.net or via chat on the website (nexcess.net).
Posted Aug 20, 2025 - 20:24 EDT
This incident affected: Support Services (Phones).