Visual Comparison Degraded
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Sep 15, 2022 - 12:37 EDT
Investigating
Our teams are currently investigating an issue causing intermittent failures while using the Visual Comparison tool. We will update this status post as more information becomes available.

If you have any questions or concerns, please contact our support team by emailing support@nexcess.net, client portal ticket, live chat, or toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Sep 13, 2022 - 10:23 EDT