Cloudflare 521 Errors

Incident Report for Server Status | Nexcess

Resolved

This issue is now resolved.
Posted Mar 03, 2022 - 16:12 EST

Investigating

We are currently aware of Cloudflare related 521 errors. Our teams are investigating at this time. We will update this post as more information becomes available.

If you have any further questions or concerns, please feel free to reach out to us at support@nexcess.net or call us at 1-866-639-2377 in the Americas, +0-808-196-5715 in the UK or 1-313-279-0722 international.
Posted Mar 03, 2022 - 15:04 EST