Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 08, 2026 - 04:00 EDT
Scheduled
Our Engineering team will be performing scheduled maintenance on SSH service configuration on every Enterprise Linux9 cloudhosts. This maintenance is being performed to enhance ssh service security and ensure continued protection against evolving security risks. This change is isolated strictly to the SSH service and legacy cryptographic algorithms will remain temporarily enabled during this phase, ensuring that older SSH clients can still connect.
- Maintenance Window: July 8, 2026 at 04:00AM ET - Duration: 2 to 3 hours
Our team will be actively monitoring the process throughout the maintenance and will keep informing you about any other changes made.
Our support team is on standby if you need help, have questions, or have concerns. You can connect with us through the following channels:
We appreciate your patience and understanding as we perform this maintenance to improve our infrastructure and continue providing reliable service. Thank you for your continued support.
Internal System Maintenance Reference: [CC-13578]
Posted Jul 02, 2026 - 17:02 EDT
This scheduled maintenance affected: Platform Operations (SSH/FTP).