DNS Service Disruption

Incident Report for Server Status | Nexcess

Resolved

The DNS propagation issue has been fully resolved. All services should now be functioning as expected. Thank you for being so patient!

If you have any questions or concerns, please email our support team at support@nexcess.net using the client portal ticket or live chat.
Posted Apr 01, 2025 - 13:39 EDT

Identified

Our team has identified the cause of the issue and is actively working on a complete resolution. We will provide further updates as progress continues.

If you have any questions or concerns, please email our support team at support@nexcess.net using the client portal ticket or live chat.
Posted Apr 01, 2025 - 13:25 EDT

Investigating

We are investigating an issue with new DNS records not propagating as expected. Our team is actively working on a resolution and will provide updates as soon as possible.

If you have any questions or concerns, please email our support team at support@nexcess.net using the client portal ticket or live chat.
Posted Apr 01, 2025 - 10:37 EDT
This incident affected: Nexcess Global DNS.