Customer Portal Degraded
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Jul 29, 2022 - 16:43 EDT
Investigating
Our teams are currently investigating an issue causing increased load times on our customer portal. We will update this status post as more information becomes available.

If you have any questions, please do not hesitate to contact a member of our support team by email at support@nexcess.enet, via live-chat or ticket through your customer portal (https://my.nexcess.net/) or by phone, toll-free at 866-639-2377 or internationally at +1.517.322.0434.
Posted Jul 29, 2022 - 14:59 EDT
This incident affected: Customer Portal.