Nexcess Phone System Update
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Jan 18, 2022 - 01:44 EST
Identified
Our phone system is currently undergoing maintenance to apply needed updates to the system. If you are unable to reach us please feel free to create a ticket through my.nexcess.net or by emailing support@nexcess.net, open a chat with our support team, or call back later and we will be with you as quickly as we can.

We thank you for your patience and will update this status with any additional details or once the maintenance is complete.
Posted Jan 17, 2022 - 23:04 EST
This incident affected: Support Services (Phones).