Support Availability
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 09:24 EST
Monitoring
Our Support team based in Texas is in a hindered state due to inclement weather and rolling power outages. You may experience delays or longer than usual wait times.

We appreciate your patience and understanding and we will continue to work as quickly and efficiently as we can.
Posted Feb 16, 2021 - 16:59 EST
This incident affected: Support Services (Tickets, Phones, Chats).