Blacklisted IPs
Incident Report for Server Status | Nexcess
Resolved
IPs have been delisted and additional monitoring has been put in place to help avoid this in the future.
Thank you for your patience.
Posted Mar 05, 2021 - 10:17 EST
Investigating
Teams are currently investigating a report of IP addresses showing on a less commonly used blacklist, and are working to resolve the issue. Some customers have experienced a delay in email delivery as a result. If you experience any issues, please feel free to reach out to our Support Team at 1.866.639.2377 or international at +1.313.279.0722.
Posted Mar 01, 2021 - 10:15 EST