Issue with SSL certificate on help.nexcess.net
Incident Report for Server Status | Nexcess
Resolved
This issue has been fully resolved. We apologize for any inconvenience or disruption to workflow this may have created.
Posted Mar 25, 2022 - 08:20 EDT
Identified
At this time, we continue to work with our knowledge base provider to resolve the issue with the SSL certificate for our Help Center. For assistance with any of our products please reach out to our support team directly via chat, ticket, or telephone at support@nexcess.net or call us at 1-866-639-2377 (US), +0-808-196-5715 (UK), or 1-313-279-0722 (Australia).
Posted Mar 25, 2022 - 05:50 EDT
Investigating
We are aware of a current issue regarding the SSL certificate used by our help documentation site help.nexcess.net . We are currently investigating this issue and will post further updates and information as it becomes available.
Posted Mar 24, 2022 - 22:27 EDT
This incident affected: Support Services (Help Center).