Incoming Phone Call Issues
Incident Report for Server Status | Nexcess
Resolved
This incident has been resolved.
Posted Feb 01, 2023 - 13:02 EST
Monitoring
Nexcess Engineering teams have resolved the issues with our phone system and they are actively monitoring our systems. Inbound calls to our Support team should be working again at this time.

If you have any further questions or concerns, please contact our support team by emailing support@nexcess.net, opening a ticket or chat in your customer portal (https://my.nexcess.net) , or by calling toll-free at 866-639-2377 or +1.517.322.0434 (international).
Posted Feb 01, 2023 - 12:40 EST
Investigating
Our team is investigating an issue with our phone system at this time. They are diligently working on this and we will update this status with more information when we have it.

In the mean time if calls are not working please feel free to contact us via live chat or ticket from your account or at support@nexcess.net.
Posted Feb 01, 2023 - 11:34 EST
This incident affected: Support Services (Phones).